Results 1 to 10 of 10

Thread: Navigation opens new browser window & IE centers, FF dpesm't

  1. #1
    Junior Member
    Join Date
    Aug 2010
    Posts
    8

    Default Navigation opens new browser window & IE centers, FF dpesm't

    Greetings,

    First experience with NOF. Good experience overall, but have two issues:

    1. Home page comes up normally. Pressing any navigation button opens second, new browser window. Further navigation works fine in second window (no additional windows open). The site is very simple and straightforward. Not sure what I could be doing to cause this.

    2. Each page is centered in IE, but is on the left margin in FF. I have clicked Center in Browser for all objects. Perhaps there is a meta-setting that I did not see. Could not locate any info in the UserGuide. Any help would be appreciated.

    Website is currently being tested in www.dev.jourdansbeautifulfood.com

    Note: also had the different text size problem in IE and FF. Thanks to mia, I was able to resolve this by using pt sizes rather than relative sizes.

    Best,
    Rob

  2. #2
    Senior Member gotFusion's Avatar
    Join Date
    Jan 2010
    Location
    www.gotHosting.biz
    Posts
    4,526

    Default

    Quote Originally Posted by robb View Post
    1. Home page comes up normally. Pressing any navigation button opens second, new browser window. Further navigation works fine in second window (no additional windows open). The site is very simple and straightforward. Not sure what I could be doing to cause this.
    Go to the 3rd tab and make sure that there is no target selected (none)

    Click image for larger version. 

Name:	navTarget..gif 
Views:	271 
Size:	8.6 KB 
ID:	372

    Quote Originally Posted by robb View Post
    2. Each page is centered in IE, but is on the left margin in FF. I have clicked Center in Browser for all objects. Perhaps there is a meta-setting that I did not see. Could not locate any info in the UserGuide. Any help would be appreciated.

    Try using the method described in this tutorial instead of center in browser http://www.gotfusion.com/tutorials/tut.cfm?itemID=4044

    NOTE: Essentials is version 7.5. also make sure your html generation is set to dynamic not fixed.
    NetObjects Fusion Cloud Linux enabled Web Hosting, support + training starts at $14.95
    NetObjects Fusion web Hosting and support + ASP + PHP + ColdFusion + MySQL + MS SQL
    FREE NetObjects Fusion Support & training comes with all web hosting accounts
    NetObjects Fusion Web Hosting: http://www.gotHosting.biz

  3. #3
    Junior Member
    Join Date
    Aug 2010
    Posts
    8

    Default

    Thank you Mike! On #1 you nailed it. Something (I don't know how, it was unintended) got in there in the Home page properties. The navigation now works properly. The unintended consequence of setting it to "none" however, has caused the browser title to remain with the Home page title, when navigating to other pages that have their own titles. Any idea what would cause this?

    I followed your instructions for #2, but with FF, it is still left. IE still centers properly. I used your instruction for v7.5 and went back and verified that I had done it. The only unusual thing I can think of is that I have it set to zero margins. Could that affect it?

    Best,
    Rob

  4. #4
    Junior Member
    Join Date
    Aug 2010
    Posts
    8

    Default

    Update on #2. Mike, I followed your instructions, but applied it to each page's layout properties. (I had already applied it to the masterborder which didn't have an effect.) By putting it into the html of each page's layout, FF now displays correctly! Thank you again.

    As for #1, an additional observation. As I page through the site both the http address bar and the browser page title do not seem to update. I have never seen this before or thought it was possible. So, it looks like you are staying in the same page when you are actually navigating pages. It also seems unusual that the navigation pages are separated by another html directory. For example, sitename.com/html/anotherpage.html. Is this how it should be in NOF? I would have expected sitename.com/anotherpage.html. Perhaps I caused this structure and that is related to the odd behavior with the address bar and browser page title.

    Hopefully, someone has an idea about this. Appreciate any guidance.

    Best,
    Rob

  5. #5
    Senior Member gotFusion's Avatar
    Join Date
    Jan 2010
    Location
    www.gotHosting.biz
    Posts
    4,526

    Default

    Quote Originally Posted by robb View Post
    Update on #2. Mike, I followed your instructions, but applied it to each page's layout properties. (I had already applied it to the masterborder which didn't have an effect.) By putting it into the html of each page's layout, FF now displays correctly! Thank you again.

    As for #1, an additional observation. As I page through the site both the http address bar and the browser page title do not seem to update. I have never seen this before or thought it was possible. So, it looks like you are staying in the same page when you are actually navigating pages. It also seems unusual that the navigation pages are separated by another html directory. For example, sitename.com/html/anotherpage.html. Is this how it should be in NOF? I would have expected sitename.com/anotherpage.html. Perhaps I caused this structure and that is related to the odd behavior with the address bar and browser page title.

    Hopefully, someone has an idea about this. Appreciate any guidance.

    Best,
    Rob
    It sounds like you have frames enabled.

    Check the 2nd tab on the MasterBorder properties palette and make sure that NONE of the frames icons are highlighted.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	frameBorders..gif 
Views:	243 
Size:	3.4 KB 
ID:	373  
    NetObjects Fusion Cloud Linux enabled Web Hosting, support + training starts at $14.95
    NetObjects Fusion web Hosting and support + ASP + PHP + ColdFusion + MySQL + MS SQL
    FREE NetObjects Fusion Support & training comes with all web hosting accounts
    NetObjects Fusion Web Hosting: http://www.gotHosting.biz

  6. #6
    Junior Member
    Join Date
    Aug 2010
    Posts
    8

    Default

    Thanks Mike. I looked at the circled box above and it was empty. However, the Top box is highlighted and has "Top(1)" under it. I would delete it, (Should I delete it?), but I don't see any option.

    Thanks again very much,
    Rob

  7. #7
    Senior Member gotFusion's Avatar
    Join Date
    Jan 2010
    Location
    www.gotHosting.biz
    Posts
    4,526

    Default

    Quote Originally Posted by robb View Post
    Thanks Mike. I looked at the circled box above and it was empty. However, the Top box is highlighted and has "Top(1)" under it. I would delete it, (Should I delete it?), but I don't see any option.

    Thanks again very much,
    Rob
    Yes, That was a generic screen shot I posted and it related to doing frame boarders (but it showed you where to look for frame sets). Just click on the highlighted icon to remove the frame.

    You will need to remove all of the layout html insert code (for centering) and add it to the masterborder palette (it did not work because of the frames)

    You will need to clean up all work files and regenerate every page again. Follow this tutorial to remove all of the old frame pages http://www.gotfusion.com/tutorials/tut.cfm?itemID=4029

    It would be a good idea to delete all files on the web server and replace them with the new ones you created.
    NetObjects Fusion Cloud Linux enabled Web Hosting, support + training starts at $14.95
    NetObjects Fusion web Hosting and support + ASP + PHP + ColdFusion + MySQL + MS SQL
    FREE NetObjects Fusion Support & training comes with all web hosting accounts
    NetObjects Fusion Web Hosting: http://www.gotHosting.biz

  8. #8
    Junior Member
    Join Date
    Aug 2010
    Posts
    1

    Default

    I had the same centering issue. Solved it like this: click on "html" on the layout properties palette. Make sure it's the "Layout Properties" palette, NOT the master border or any layout region properties!! Then, click on "Beginning of Body" tab and enter <CENTER> (doesn't have to be all caps, but include the < > ). Then click on "End of Body" tab and enter </CENTER> (again include the < > ). Do this on every single page! This solved the issue for me completely.

    Michael
    www.microtonemusic.net

  9. #9
    Junior Member
    Join Date
    Aug 2010
    Posts
    8

    Default

    Mike, that did the trick. Who knew that one click would clean up the problem. I could not find any info in the UserGuide that was relevant. Thanks so much. Thanks also for the cleanup tutorial.

    Best,
    Rob

  10. #10
    Junior Member
    Join Date
    Aug 2010
    Posts
    8

    Default

    Thanks for your post Michael. In looking into this on the web, I found some info suggesting that <center> is an older concept and is being phased out and may not be supported down the road. I think Mike's suggestion is probably the safer one. It would have been relatively painless if I didn't have that Top frame set.

    I am very impressed with the quality of posts on this board. As we move toward integrating E-Commerace I may have another question or two. Thanks again.

    Best,
    Rob

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •