Results 1 to 6 of 6

Thread: SMTP Question

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default SMTP Question

    I have a Contact form on my site. I am using a free hosting site until I get this web site completed at which time I'll move it to a new paid host. In the meantime, I'm just trying to get things working.

    I publish the site to the free host and go to my Contacts page and fill in the details and submit. After a short wait, I get this error:

    [Error 201] Could not send email to 'stevec5375@gmail.com' from 'stevec5375@gmail.com' using the SMTP server 'smtp.gmail.com:587'. Please check if you have access to the SMTP server.

    Since I'm using a free hosting site, I do not have an email account with them so I'm using Google's SMTP server. I know my account credentials and port are correct. No matter what I do, I can't get an email to send.

    Does anyone have a clue as to what I'm doing wrong?

    Here's a link to the page I'm working with:
    http://stevecannon.limewebs.com/Contact/contact.php

  2. #2
    Administrator Mike's Avatar
    Join Date
    Jan 2010
    Location
    Doylestown, PA
    Posts
    524

    Default

    Hi Steve,
    If you're utilizing the Forms Handler v2 component and gMail as a SMTP relay try using port 465 instead. Also make sure to use SMTP auth and SSL turned on, please see the attached screenshot.

    More information about gMail's SMTP setup can be found here http://mail.google.com/support/bin/a...n&answer=13287
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	forms handler..png 
Views:	196 
Size:	28.7 KB 
ID:	874  
    Mike
    NetObjects Technical Support
    forums.NetObjects.com

  3. #3

    Default

    Hi Mike,

    I am using the new FormsHandler v2 component. I tried using your settings with my user/password combo and it resulted in the same error. I tried it on both my localhost and a remote web host and the same result.

    My localhost has a WAMPServer stack on it (Apache, MySQL, and PHP).

    I do not have the "Write to Database" checkbox checked because I only want to send email.

    I am at my wits end trying to get this to work.
    Last edited by stevec5375; 03-10-2011 at 04:18 PM.

  4. #4
    Administrator Mike's Avatar
    Join Date
    Jan 2010
    Location
    Doylestown, PA
    Posts
    524

    Default

    Writing to a DB is optional and can be unchecked. You'll still need to run through the Database and File Upload wizards.

    If you're running on your own stack make sure firewall settings are configured to allow in/out traffic for external SMTP /w SSL and necessary SSL modules are installed.
    Mike
    NetObjects Technical Support
    forums.NetObjects.com

  5. #5

    Default

    Quote Originally Posted by Mike View Post
    Writing to a DB is optional and can be unchecked. You'll still need to run through the Database and File Upload wizards.

    If you're running on your own stack make sure firewall settings are configured to allow in/out traffic for external SMTP /w SSL and necessary SSL modules are installed.

    Thanks for your help on this Mike. I finally got it to work.

    I had to enable the extension for SSL in my php.ini file: extension=php_openssl.dll
    I had to add the following section to the php.ini file as well:

    [mail function]
    ; For Win32 only.
    ; http://php.net/smtp
    SMTP = smtp.gmail.com
    ; http://php.net/smtp-port
    smtp_port = 465
    auth_username = <enter your SMTP server login user name here>
    auth_password = <enter your SMTP server login password name here>

    ; For Win32 only.
    ; http://php.net/sendmail-from
    sendmail_from = <enter your "from" email address here>

  6. #6

    Default

    Quote Originally Posted by Mike View Post
    Writing to a DB is optional and can be unchecked. You'll still need to run through the Database and File Upload wizards.

    If you're running on your own stack make sure firewall settings are configured to allow in/out traffic for external SMTP /w SSL and necessary SSL modules are installed.
    Why would you need to run through the Database and File Upload wizards when the checkbox is unchecked and you don't plan to use it? This is not intuitive in the dialog at all.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •