Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: How to create a simple Log in with Username and Password

  1. #11
    Junior Member
    Join Date
    Aug 2011
    Location
    Perth, Western Australia
    Posts
    10

    Default

    I'm probably on the wrong thread but can't find how to start a new one so hopefully someone can help me.

    Like everyone else, I just want to set up a secure area on my website with a log-on with username and password and think I've put all the right components in all the right places but I can't figure out the database part. I've read all the tutorials and they assume a certain amount of knowledge of servers and scripts and things which is all Greek to me. Can anyone walk me through configuring the database settings in a way that assumes I know absolutely nothing about html, php etc?

  2. #12
    Senior Member LBA's Avatar
    Join Date
    Jan 2010
    Location
    California
    Posts
    543

    Default

    If, as you say, you truly know "absolutely nothing about html and php", then the answer is a definite NO! But most likely you're being too harsh on yourself. There are approximately a billion tutorials on the 'net that will show you how to build a database. What you will need to do is sit down and define your intent as best you can, break the project into pieces and then begin to Google it step by step. Guidance is available here but the questions need to be way more specific.

  3. #13
    Junior Member
    Join Date
    Aug 2011
    Location
    Perth, Western Australia
    Posts
    10

    Default

    Thank you for your quick response.

    On the General tab of each of the secure site components, it asks me to type in the 'path to database'. It already has "../db/users.csv" typed in. I don't know whether I should leave that or change it to something else - and if so, then what? When I click on the DB creation wizard, the areas are all greyed out and don't allow any input.

  4. #14
    Senior Member LBA's Avatar
    Join Date
    Jan 2010
    Location
    California
    Posts
    543

    Default

    Aha... you're using the Secure Site component. An answer to your question can be found.... but not from me. I write custom code for my secure sites but I'm sure someone with experience with that component will chime in soon. Also, dare I ask the obvious.... have you checked the NOF documentation?

  5. #15
    Junior Member
    Join Date
    Aug 2011
    Location
    Perth, Western Australia
    Posts
    10

    Default

    Yes, I've been following a tutorial on building a secure site using the secure site components.
    http://launchpad.netobjects.com/html/membership4.html
    I've been able to understand everything else - just can't get my head around the path to database part.

  6. #16
    Junior Member
    Join Date
    Aug 2011
    Location
    Perth, Western Australia
    Posts
    10

    Default

    Plus, it seems from reading other posts that my db creation wizard isn't working - something other people seem to also be having problems with......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •