Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Drop down menus not working on iphone

  1. #1
    Junior Member
    Join Date
    Oct 2011
    Posts
    9

    Default Drop down menus not working on iphone

    The web site I have created utilities a horizntal navigation bar of parent pages and drop down menus for the child pages. The web site and drop down menus works fine on PC internet explorer versions 8 and 9, Google Chrome, and Safari for the PC. However, when I view the web site on an iphone or android phone, the drop down menus on the navigation bar do not work. Nothing drops down. Everything else on the web site works great on the phones (including news ticker, movie, text, links, and pics). Is there a some setting or HMTL code that is required for the navigation bar for the drop down menus to work properly on mobile devices?

    Thanks.

  2. #2
    Senior Member franko's Avatar
    Join Date
    Apr 2010
    Location
    Tasmania Australia
    Posts
    1,549

    Default

    This is a useful discussion.

  3. #3
    Administrator Mike's Avatar
    Join Date
    Jan 2010
    Location
    Doylestown, PA
    Posts
    430

    Default

    Quote Originally Posted by blperez View Post
    The web site I have created utilities a horizntal navigation bar of parent pages and drop down menus for the child pages. The web site and drop down menus works fine on PC internet explorer versions 8 and 9, Google Chrome, and Safari for the PC. However, when I view the web site on an iphone or android phone, the drop down menus on the navigation bar do not work. Nothing drops down. Everything else on the web site works great on the phones (including news ticker, movie, text, links, and pics). Is there a some setting or HMTL code that is required for the navigation bar for the drop down menus to work properly on mobile devices?

    Thanks.
    Hi blperez, could you please post a link to your site that is experiencing the menu issue on smartphones?

    Thanks!
    Mike
    NetObjects Technical Support
    forums.NetObjects.com

  4. #4
    Junior Member
    Join Date
    Oct 2011
    Posts
    9

    Default

    Yes. The web site I am having toruble with is the following: www.torotools.com
    The web site works great on a PC running IE8, IE9, Chrome, or Safari. Drop downs do not work on a iphone or motorola phone running Android

  5. #5
    Administrator Adam's Avatar
    Join Date
    Jan 2010
    Location
    Pennsylvania
    Posts
    338

    Default

    Quote Originally Posted by blperez View Post
    Yes. The web site I am having toruble with is the following: www.torotools.com
    The web site works great on a PC running IE8, IE9, Chrome, or Safari. Drop downs do not work on a iphone or motorola phone running Android
    Hi blperez,

    Get ready...

    Our internal testing seems to show the navigation working as "intended" for what is currently in NetObjects Fusion XII. This doesn't mean we can't improve upon it though. Let me outline our testing, then offer some alternatives. Then we can offer what our thoughts are on future (not AU2) enhancements we could provide.

    We have a variety of phones and tablets in-house running Android and IOS. We tested a range of websites including torotools.com, NetObjects.com, and several mainstream websites to see how submenus were handled. For some reference, a "hover" on a touchscreen is represented by a click. Android seems to work as we expect it would, by clicking and holding the submenus drop down. You have to swipe away (off the menus) and then click the submenu that you wish to navigate to. On IOS, there was no way to initiate the submenus so unless you have some time to view the submenus before the page loads (think off network) then they simply do not show up.

    These results were compared to a few mainstream websites (not mobile sites) and the outcome was the same.

    Now, there are a few solutions that we can offer. NetObjects Fusion XII ships with a smartphone template. You can open it by clicking File > New Site > From Template. NetObjects Fusion will default to the Templates directory where you will see Smartphone Site.zip.

    Bonus, I have attached a version of the template with new designs to this post. It will be available soon via the Online view and Cloudburst so think of this as a forum exclusive for now!

    Now you need to a) use a custom script to recognize mobile visitors and redirect them to a sub directory where you will publish your mobile website or b) provide your users a link, preferably towards the top of the page, to let a user visiting from a mobile device know to click here.

    Also, if you don't want to go through the above trouble, we have also creatively used section titles in a navigation as a workaround. Here is an example:

    http://adam.netocorp.com/mobile1

    If your not familiar with section titles, basically it is a placeholder button that isn't linked. So, as you can see in your mobile device, if you click on the "Title1" button, the pages Mobile 1-5 drop down and you can click on the page you want. It works the same on a computer so your not left with a decision to leave anything out to play nice with your Mobile visitors.

    To add Section Titles:

    1. Select your nav in the Page view
    2. From the Navigation Bar Properties palette change your navigation to Custom
    3. Click Edit Custom
    4. Click Add Title to add a section title, name it what you want
    5. Add your pages as child pages to the Section title


    Click image for larger version. 

Name:	confusing instru&#.png 
Views:	204 
Size:	60.5 KB 
ID:	1044

    We have definitely been thinking of integration with Mobile and we have some cool ideas that we would like to implement in the future.

    Nothing set in stone yet but perhaps some new jQuery framework or some changes to the Javascript that the navigation uses. We are open to suggestions if you have an idea as well. Drop us a line, reply, or use the NetObjects Fusion Suggestions forum here.
    Attached Files Attached Files
    Adam
    NetObjects Technical Support

  6. #6
    Senior Member mia's Avatar
    Join Date
    Apr 2010
    Location
    Germany /Deutschland
    Posts
    809

    Default

    Hi Adam,

    thank you very much for your detailed post.
    This issue is puzzling me since a while.
    During the day when I'm not at home I'm using an iPad.

    I visit Tommy's NOF Help Pages very often because we link to his tuts regularly in our forum.
    He's using a dropdown menue for his themes list.
    And since a while this dropdown menue is not working anymore.
    When I touch the motherbutton Themen, the dropdown shows up for a split second.
    But before I get the chance to pick a child page I'm getting linked to the mother page "Themen"

    I tested your netobjects.com site, it's just the same.

    But, when I said Tommy's menue is not working properly ANYMORE, I meant it was working before.
    The menue was working properly in NOF 11. At least in the last 1 1/2 years since I use my iPad.
    And since he imported his help pages into NOF XII this problem occurred.
    http://www.tommyherrmanndesign.com/nof/
    Last edited by mia; 10-25-2011 at 06:20 PM.
    http://www.nof-community.de
    NOF-Community, Hilfe, Support, Tutorials, Anleitungen, Tipps und Tricks für Netobjects Fusion und SwissKnife Komponenten

  7. #7
    Junior Member
    Join Date
    Oct 2011
    Posts
    9

    Default

    Thanks Adam for the in-depth answer to my question. I will certainly try your suggetion for a the section titles.

  8. #8
    Junior Member
    Join Date
    Oct 2011
    Posts
    9

    Default

    Adam,

    I went back and checked my web site and sure enough, I AM using Section Titles for my drop downs. Interestingly, your test site works fine on a mobile device while my site does not. I will try to 'rebuild' the navigation bar and see if that fixes the problem. Otherwise, my only option is to create a mobile version of the web site.

  9. #9
    Administrator Adam's Avatar
    Join Date
    Jan 2010
    Location
    Pennsylvania
    Posts
    338

    Default

    Quote Originally Posted by blperez View Post
    Adam,

    I went back and checked my web site and sure enough, I AM using Section Titles for my drop downs. Interestingly, your test site works fine on a mobile device while my site does not. I will try to 'rebuild' the navigation bar and see if that fixes the problem. Otherwise, my only option is to create a mobile version of the web site.
    I can't take a screenshot on Android until Ice Cream Sandwich but...I just went back and checked it out and you are right, your already using section titles (doh). Anyways, I tested again from a couple of Android devices with the same results, the nav is currently working as intended.

    Also, you might want to try and use the trackball on the Android device as that works great as well. Perhaps you have already changed the navigation since your last post? Check my time stamp and let me know (5:09 EST).
    Adam
    NetObjects Technical Support

  10. #10
    Junior Member
    Join Date
    Oct 2011
    Posts
    9

    Default

    Adam,

    OK. I tried the section titles and still a no go. My web site works fine on a PC but the drop down menus still do not work on an iphone. I did notice the your test site works fine on both a PC and mobile devices, so I am not sure what I am doing wrong. Is there some code that can be inserted before the navigation bar html code to allow the drop downs to work right?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •