Results 1 to 7 of 7

Thread: Help! Facebook fan page box not showing/working

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Posts
    7

    Unhappy Help! Facebook fan page box not showing/working

    I'm complete stumped even after having read tips here at the forum.

    I have this code (two snips, one for the java) from facebook which I try to insert on my home page by making a text box and pasting both the codes below it into the text box using "ctrl+t" - but - nothing shows up when I test using preview, neither in ie or firefox. What am I doing wrong?

    <div id="fb-root"></div>
    <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) {return;}
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1";
    fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>

    <div class="fb-like-box" data-href="http://www.facebook.com/nytaarstale" data-width="292" data-height="400" data-show-faces="false" data-stream="true" data-header="true"></div>

  2. #2
    Senior Member RayC's Avatar
    Join Date
    Apr 2010
    Location
    Toronto-ish, Canada
    Posts
    1,732

    Default

    Not sure, exactly. Generally I only use CTRL-T to insert code that needs to be positioned on the page. I'd use the HTML... button in the Layout Properties panel to insert the javascript bits.

    Try this... On the page in question, click HTML... and do the following:

    HTML Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML>
    <HEAD>
    <TITLE> Title of Page will be generated by NetObjects Fusion. </TITLE>
    
    
    
    <!-- NetObjects Fusion Generated HEAD HTML-->
    
    </HEAD>
    <BODY NetObjects Fusion Generated BODY Parameters 
    
    >
    
    --->>> INSERT JAVASCRIPT HERE <<<---
    
    <!-- NetObjects Fusion Generated BODY -->
    
    </BODY>
    </HTML>
    Be careful about where that closing ">" appears in the <BODY.... > tag relative to where you insert the code.

    HTH
    Ray Cambpell
    Sounds In Sync
    Linked in

  3. #3
    Junior Member
    Join Date
    Nov 2011
    Posts
    7

    Default

    Thanks for the reply - still no dice...

    Trying to think: The HTML-box in the layout frame keeps "collapsing" so its too small to fit the sizeable fan page box - maybe that's the reason?

    Alternatively I could also use an in-line frame. However, something is not working as it should because I have no idea how to reference the i-frame code. Made a textbox, but get this during my preview - a step by step for the inline frame could maybe solve the issue, at least the box is there to see (LOL!)... The problem here is that my i-frame does not look to the net to find the frame - it should be so easy Arrrghhhhh...

    Firefox cannot find til file /C:/Users/FMM/Documents/NetObjects Fusion 12.0/User Sites/Nu Gælder Det Danmark/Preview/<iframe src='//www.facebook.com/plugins/likebox.php?href=http://www.facebook.com/nytaarstale&amp;width=292&amp;height=427&amp;color scheme=light&amp;show_faces=false&amp;border_color &amp;stream=true&amp;header=true' scrolling='no' frameborder='0' .
    Last edited by maiaibing; 11-13-2011 at 01:25 PM.

  4. #4
    Senior Member
    Join Date
    Oct 2011
    Posts
    171

    Default

    try Local Publish, not Preview. Javascript gets fully generated only when publishing from within NOF (as far as I remember).

  5. #5
    Junior Member
    Join Date
    Nov 2011
    Posts
    7

    Lightbulb Local publishing vs remote vs preview?

    Quote Originally Posted by Peter View Post
    try Local Publish, not Preview. Javascript gets fully generated only when publishing from within NOF (as far as I remember).
    Not sure - could be something here - however, local published also did not solve it. Wonder if I need to publish it on-line to see the result. Anyone know for sure or who has an embedded inline frame they can test out (I do not have my host ready yet)??

  6. #6
    Senior Member RayC's Avatar
    Join Date
    Apr 2010
    Location
    Toronto-ish, Canada
    Posts
    1,732

    Default

    I have a site with a FB Like button, and looking at the Local Publish, it displays and even shows the number of "Likes". Just looking at the site now (it's a couple of years ago I did this), it does NOT seem to have any javascript embedded. It uses the I-Frame method like so:
    HTML Code:
    <iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.domain.ca%2F&amp;
    layout=button_count&amp;
    show_faces=false&amp;
    width=90&amp;action=like&amp;
    font=verdana&amp;
    colorscheme=light&amp;height=21" scrolling="no" frameborder="0" style="border:none; 
    overflow:hidden; 
    width:90px; 
    height:21px;" allowTransparency="true">
    </iframe>
    You could try the same by substituting your own URL and changing the parameters to suit.
    Ray Cambpell
    Sounds In Sync
    Linked in

  7. #7
    Junior Member
    Join Date
    Nov 2011
    Posts
    7

    Default

    Thank you all for your suggestions. Nothing seemed to work until - suddenly - Bingo! - it showed up as an iframe on one of my externally published site. Seems to me, that this is the only way to get to see the facebook fanpage or like button etc. Anyway you certainly encouraged me to keep trying!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •