Results 1 to 3 of 3

Thread: Problems with FORMS

  1. #1
    Junior Member
    Join Date
    Aug 2010
    Posts
    6

    Default Problems with FORMS

    Hi all:
    I am trying to add a form using coffeecup Web Form builder( I tried with the form funtion in Fusion 2013 and wanted to rip my hair out - If there is a simple explaination on how to make it work, I would prefer to use the built in form tool as I hope it would be easier to master). According to CoffeeCup, I am supposed to insert the following code INTO the page I want the form to appear in (Code is at the bottom of this message). When I preview the form in CoffeeCup, it is fine.(FIG1)

    I have a page called FORM in my site and I opened it in "Page" (1) and then clicked on the "HTML"(2) button on the layout properties, then clicked on "bodyStart" (3) in the Page HTML box and pasted the code from CC Web into the page (4). (FIG 2)

    When I preview the page, All I get is the actual code shown in a distorted page view (FIG 3)

    I have tried many alternates of this and cannot seem to figure out how to get this transparent form onto the page created for it using the website theme. I have tried to add the form page (smartstart.html) into the form body using the "advanced Tools" - "Custom Components" (FIG 4) but that makes the form show up distorted and improperly laid out (FIG 5).

    Where am I going wrong?

    CoffeeCup CODE:
    <script type="text/javascript">document.write(unescape("%3Ciframe id=\"fb_iframe\" src=\"SmartStart.php" + window.location.search + "\" width=\"600\" height=\"1068\"allowtransparency=\"true\" scrolling=\"no\" frameborder=\"0\"%3E&lt;a href=\"SmartStart.php\" title=\"SmartStart\"&gt;Check out my CoffeeCup Form&lt;/a&gt;%3C/iframe%3E"));</script>
    <noscript>
    <iframe width="600" height="1068" style="border:none; background:transparent; overflow:hidden;"
    id="fb_iframe" src="SmartStart/SmartStart.html">
    &lt;a href="SmartStart.php" title="SmartStart"&gt;Check out my CoffeeCup
    Form&lt;/a&gt;
    </iframe>
    </noscript>
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	FIG 1.jpg 
Views:	278 
Size:	45.0 KB 
ID:	1584   Click image for larger version. 

Name:	FIG 2.jpg 
Views:	284 
Size:	135.2 KB 
ID:	1585   Click image for larger version. 

Name:	FIG 3.jpg 
Views:	285 
Size:	43.6 KB 
ID:	1586   Click image for larger version. 

Name:	FIG 4.jpg 
Views:	263 
Size:	81.1 KB 
ID:	1587   Click image for larger version. 

Name:	FIG 5.jpg 
Views:	268 
Size:	57.8 KB 
ID:	1588  


  2. #2
    Senior Member LBA's Avatar
    Join Date
    Jan 2010
    Location
    California
    Posts
    543

    Default

    In your third image, it shows that you are attempting to do a local preview of a page that contains PHP code. Under most circumstances, that is not possible. Pages containing PHP code generally need to be uploaded to a server in order to work correctly. You also need to be sure that the filename extension of any page containing PHP code has been changed from .html to .php... which is not the case in the image you have shown us.

  3. #3
    Junior Member
    Join Date
    Aug 2010
    Posts
    6

    Default

    Thank you for the direction. The html in that code snippet was generated by the coffeecup program and is actually valid. However you did help A LOT in pointing out that the code needed to be placed into a text box onn the form page and that the preview was the was not going to show the php. Once I posted the embedded code as instructed and then uploaded the ancillary files to the server, the form works perfectly.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •