Results 1 to 10 of 22

Thread: Carousel broken files

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member
    Join Date
    Dec 2013
    Posts
    19

    Angry Carousel broken files

    My carousels work fine when published locally, but images show as broken when published to website.
    Any help appreciated

  2. #2
    Senior Member franko's Avatar
    Join Date
    Apr 2010
    Location
    Tasmania Australia
    Posts
    2,640

    Default

    If the site works perfectly in Local Publish the best solution, frankly, is to use an ftp program such as filezilla to upload the files to your server. If you cannot publish properly through NoF either you have incorrect parameters set in Publish View or, more likely, you have incorrectly set file/directory permissions on your server. And that's a question for you host's support.

  3. #3
    Junior Member
    Join Date
    Dec 2013
    Posts
    19

    Default

    Franko, thanks for your response. I was initially using Filezilla to ftp the published files to my website, but when that didn't work I used NOF to publish to web. Still a problem with this.
    I can't see any options on my host to set any file permissions.
    I have since downloaded the files back from website back to my computer & that works correctly, so still scratching my head.

  4. #4
    Senior Member gotFusion's Avatar
    Join Date
    Jan 2010
    Location
    www.gotHosting.biz
    Posts
    4,529

    Default

    Can you post a URL to the site so we can see why you are having the problem.

    troubleshooting without seeing is no better than guessing. My guess is the images did not get uploaded to the folder that the code is looking for them in but without seeing where the code is looking for the images this is just a guess.
    NetObjects Fusion Cloud Linux enabled Web Hosting, support + training starts at $14.95
    NetObjects Fusion web Hosting and support + ASP + PHP + ColdFusion + MySQL + MS SQL
    FREE NetObjects Fusion Support & training comes with all web hosting accounts
    NetObjects Fusion Web Hosting: http://www.gotHosting.biz

  5. #5
    Junior Member
    Join Date
    Dec 2013
    Posts
    19

    Default

    This is just a test page with only a carousel with 2 pics.
    http://www.mkcyclestest.mkcycles.co.uk/

    It's a test subdomain site on 1&1
    As I said before, if I ftp this site back to my computer, when I run it locally, the carousel runs OK, apart from the fact that I get warning message about the activex that I have to accept. (BTW when I run from website I don't get error message it just runs but the rotating pics just show as X)
    FYI I'm new to nof & very pleased with how easy it is to generate website. I'm trying to get this set up for my son's cycle shop & the carousel would be a great way to give a quick tour around the shop

  6. #6
    Senior Member franko's Avatar
    Join Date
    Apr 2010
    Location
    Tasmania Australia
    Posts
    2,640

    Default

    Neither of your images has file extensions, therefore the browser does not know what type of file they are. Therefore it doesn't display them:

    <ul class="jcarousel-skin-nof nof-carousel">
    <li><img src="./_wsb_keyvisual" style="max-width: 100%" alt=""></li>
    <li><img src="./2013-02-01-751" style="max-width: 100%" alt=""></li>
    </ul>

    Try saving your images with an extension (.jpg, .png or whatever) and I'll bet it works ok.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •