Results 1 to 3 of 3

Thread: Several major problems with external script in NOF 2013

  1. #1
    Junior Member
    Join Date
    May 2014
    Posts
    1

    Default Several major problems with external script in NOF 2013

    Hi,

    I am using the native carousel in the master border, which I would like to use on most of my site. However, one page contains a form script generated by Simfatic Forms, which I have pasted into the html of an empty text box. When I preview or publish the site, the carousel does not work on this page - all the images contained in the carousel appear one underneath the other, vertically, all down the page.

    I gave up on the carousel for this page and decided to create a new master border, based on the original one but without the carousel (just a static image file). When I tried this, the navigation bar kept using the Primary button style for the Home button but correctly used the custom style for the rest of the buttons. Then, when I published the site without the carousel, the nav bar disappeared. Through all this, the form works fine, by the way.

    My question is: am I doing something basic and stupid or is it simply not possible to use the external script with NOF. I have used this script with other website design applications and it never gave me any trouble.

    Can anyone help? (I am pasting the form script below, in case it is of help).

    Thanks

    <script src='http://www.mediterraniacyclingtours.com/forms/BikeRental/scripts/jquery-1.7.2.min.js' type='text/javascript'></script>
    <script src='http://www.mediterraniacyclingtours.com/forms/BikeRental/scripts/jquery.sim.utils.js' type='text/javascript'></script>
    <div id='sfm_container_div_BikeRental'></div>
    <script type='text/javascript'>new sfmFormObj('sfm_container_div_BikeRental','http://www.mediterraniacyclingtours.com/forms/BikeRental/BikeRental.php?sfm_from_iframe=1',908);</script>

  2. #2
    Senior Member franko's Avatar
    Join Date
    Apr 2010
    Location
    Tasmania Australia
    Posts
    2,613

    Default

    Are you using Ctrl-T to paste the code into the text box or are you just pasting the code directly into the text box? If the latter, there's your problem

  3. #3
    Senior Member RayC's Avatar
    Join Date
    Apr 2010
    Location
    Toronto-ish, Canada
    Posts
    1,731

    Default

    You may have a jQuery conflict with two separate calls to jQuery - one for the carousel and one for your form.

    Try deleting the highlighted section from your form code and see if that works:

    <script src='http://www.mediterraniacyclingtours.com/forms/BikeRental/scripts/jquery-1.7.2.min.js' type='text/javascript'></script>
    <script src='http://www.mediterraniacyclingtours.com/forms/BikeRental/scripts/jquery.sim.utils.js' type='text/javascript'></script>
    <div id='sfm_container_div_BikeRental'></div>
    <script type='text/javascript'>new sfmFormObj('sfm_container_div_BikeRental','http://www.mediterraniacyclingtours.com/forms/BikeRental/BikeRental.php?sfm_from_iframe=1',908);</script>
    Ray Cambpell
    Sounds In Sync
    Linked in

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •