Results 1 to 2 of 2

Thread: RSS plug in NOT working. Either Fusion 12 OR 13.

  1. #1

    Unhappy RSS plug in NOT working. Either Fusion 12 OR 13.

    I have pages that pull RSS feeds using the XMLFetch script that is provided. It used to work fine, but now all the RSS feed spots just say 'Loading...' but the feeds are still there and good. Why does is not work anymore. You can see the non functioning feeds on these pages :
    http://www.footballgameschedules.com...fl-scores.html (Feed is on right side, just continues to say 'Loading..'.)
    http://www.footballgameschedules.com...standings.html (Feed is on right side, just continues to say 'Loading..'.)
    http://www.eminemtour.com/Eminem-Mer...rchandise.html

    The feeds DO show up in OLDER versions of Windows (a machine here with Windows XP Pro in IE8 shows the RSS feed fine!), but not on any new device or OS or Browser.

    What can the problem be? All is in place and I even opened a ticket with my host that tried a ton and could not get it to work. The ticket is pasted below:

    -----------------------------------
    Your case was forwarded to me and I have carefully investigated it. The very first thing that I noticed was that the method to insert the RSS feeds on each of the 3 pages that you mentioned was done in an identical manner, using the same piece of code as the one below (taken from the nfl-scores.html document at http://www.footballgameschedules.com...-scores.html):



    Code:

    <script src="../scripts/xmlextras.js" type="text/javascript"></script>
    <script type="text/javascript">
    document.write('<ul class="treemenu" id="ID1403288129649">');
    insertContent("./scripts/xmlfetch.php?url=http%3A%2F%2Fsports.espn.go.com%2 Fespn%2Frss%2Fnfl%2Fnews", "../scripts/rssFeeds_1347046195859.xsl", "ID1403288129649", "Loading...", 3600, "en");
    document.write('</ul>');
    </script>


    For every page the RSS content is inserted using a PHP script named xmlfetch.php (that appears to be identical for all websites) and an URL to the actual feed passed as a query string to the script itself. What grabbed my attention at first was the way that the URL to the feeds was passed to the xmlfetch.php through a query string. A query string itself is a part of an URL, and to my knowledge the only correct application of a query string is when using an actual URL. Yet, in the code above the xmlfetch.php script is not invoked through an URL, but rather the path to the script relative to the location of the HTML document that delivers the page is supplied. It was my believe that the query string argument would not be correctly passed along to the xmlfetch.php script that could result in the issue at hand. That is why I tweaked the piece of code above for the footballgameschedules.com/html/nfl-scores.html page to:


    Code:

    <script src="../scripts/xmlextras.js" type="text/javascript"></script>
    <script type="text/javascript">
    document.write('<ul class="treemenu" id="ID1403288129649">');
    insertContent("http://www.footballgameschedules.com/html/scripts/xmlfetch.php?url=http://sports.espn.go.com/espn/rss/nfl/news", "../scripts/rssFeeds_1347046195859.xsl", "ID1403288129649", "Loading...", 3600, "en");
    document.write('</ul>');
    </script>


    inserting the xmlfetch.php script with a full URL.

    The issue remained however, and I reverted these changes and inspected the page at http://www.footballgameschedules.com...fl-scores.html using my Firebug console but did not find any errors that would suggest what is causing the issue.

    I also traced the system calls made when the page at http://www.footballgameschedules.com...fl-scores.html is accessed and the xmlfetch.php script called out, but could not find any errors in the result of the trace as well.

    I also parsed the server access and error logs and did not find any indication of error. Checking the logs in real time while reloading the page at http://www.footballgameschedules.com...fl-scores.html also did not produce an error.

    I tried using different PHP versions for the xmlfetch.php script, however still without success.

    The feed pages themselves are accessible. Using the Lynx command-line browser I was able to access both URLs http://www.footballgameschedules.com...n/rss/nfl/news and http://sports.espn.go.com/espn/rss/nfl/news while logged in via SSH with your cPanel user.

    I also suspected that there might be additional files included within the scripts invoked to deliver pages where the RSS feeds are present, so I tried to properly enable SSI for this website, although it does not seem this is the case, as the issue still remained present.

    You also mentioned that on a compute running an older OS the feeds do appear. This lead me to believe that the issue could be a browser-side restriction of a sort, that is not present in newer browser versions. For instance, web browsers often restrict including files on a given page from remote locations for security reasons, especially when JavaScript is used. I applied several custom .htaccess rules to lift this restriction for the footballgameschedules.com website, I am afraid however the the situation remained unchanged.

    I also tried restoring the content of the footballgameschedules.com website from the oldest available daily backup of your Cloud server (made on June 13th), however this did not resolve the issue as well. I reverted this change by restoring a backup of the site that I had made right before the backup restore from June 13th. I reverted any other change that I had made as well.

    Given that the feeds appear to be correctly accessible both in my browser and from the server's command line I believe the issue to reside with the way the they are inserted into the pages. I am afraid that such website-related issues are at times beyond the scope of our expertise. I would advise you to check with the website's developer, or a third party professional web developer, who could dedicate the time to examine the structure of the website and in turn provide you with further assistance.

    Best Regards,
    Lubo K.
    Technical Support Supervisor

  2. #2

    Default

    Since NetObjects almost never replies here and if you cant find help from another user, you're screwed. So I found another method to putting an RSS feed on your site. It integrates OK and is very customizable, although realize you are relying on THEIR server to be up. So NetObjects still has to fix the RSS plug in issue (and get it to work on new browsers) OR you can use this http://feed.mikle.com/ Enjoy

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •