Results 1 to 4 of 4

Thread: Cannnot change TabTop style (MFL) - error "Encountered an improper argument"

  1. #1
    Senior Member
    Join Date
    Sep 2010
    Posts
    144

    Default Cannnot change TabTop style (MFL) - error "Encountered an improper argument"

    I upgraded to NOF13 because I want to have tabbed sections on my shopping page.
    I want the colour style to match my branding, but I cannot change the style.
    I get the error message "Encountered an improper argument"
    I followed the tutorial here:
    http://netobjects.com/en/nof/11/00/o...ab_Top_MLR.pdf
    and downloaded their example PNG image to ensure the file format was correct.
    NOF support offered that my system Java was out of date, but checked that - all good.

    I also tried directly editing the CSS from the styles section to change the file - it did not change the output style at all.

  2. #2
    Senior Member
    Join Date
    Apr 2010
    Location
    Sydney
    Posts
    1,942

    Default

    what is your Nof version number? do you have update5?

    which OS and which IE?

  3. #3
    Senior Member
    Join Date
    Sep 2010
    Posts
    144

    Default

    I managed to resolve that problem - not sure how in hindsight - tried a different project and problem went away..

  4. #4
    Senior Member
    Join Date
    Sep 2010
    Posts
    144

    Default Encountered an improper argument

    Okay turns out problem remains - I cannot change the image being used by tab top using the menu.
    My main website is using a style built up by myself over time - the css code for tab tops shows it gets the image style from the netobjects program directory.
    So the only way Ive found to change the tab type image is to actually copy a new tab top.png image over the default one.
    The strange thing is, I have created a test website using a built in style, and it also has the following in the style sheet tab top css view:
    background: url("file:///C:/Program Files (x86)/NetObjects/NetObjects Fusion 2013/NetObjects System/Resources/mlr/tab_top.png") no-repeat;
    But thats not the tab_top.png image being used, so very confusing. I must assume NOF substitutes this at build time.
    Trying to change the tab-top.png within the newly created site based on built in style also got the error message 'Encountered an improper argument'
    Definately some confusion going on here, or something not working according to the tutorial mentioned above.

    Having swapped out tyhe image in a rather hacky way, I now move on to try and get the border outlines to look correct for open tabs. Changing the tab font will be another struggle

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •