Results 1 to 4 of 4

Thread: Publish Error "File in use"

  1. #1
    Junior Member
    Join Date
    Mar 2014
    Posts
    3

    Default Publish Error "File in use"

    Just updated my website and tried to publish - updates only - and got the following error:

    Can't copy file: C:\WorkArea\BU-Work\My WebSite\NPPB12\NPPB\Preview\index.html
    The process cannot access the file because it is being used by another process.

    This was after a system restart and then only with Netobjects Fusion running.
    As my site uses many old style Gallery pages - no longer present in version XII - I saved a old page with a gallery on it as a template which was then inserted three times before being updated to create three new gallery pages. Apart from a few links being added that's all that was updated.
    Any ideas as to which process is blocking the publishing operation?

    Thanks

  2. #2
    Senior Member franko's Avatar
    Join Date
    Apr 2010
    Location
    Tasmania Australia
    Posts
    2,507

    Default

    Sounds to me like you may have upgraded to Windows 10. Lots of old software has problems with the latest windows. Hell, even new software has problems with windows 10.

  3. #3
    Junior Member
    Join Date
    Mar 2014
    Posts
    3

    Default

    Thanks for response.
    I am running Windows 10 with all (I think) updates applied. Just tried running Fusion.exe in compatability mode (Win8) with and without the additional permissions option checked but it made no difference.
    The file index.html has no attributes set (like read only, etc) and can be moved to another folder.
    Publishing a "current Page" only works with other pages, just not with index.html. I suppose I could update all the changed pages and maybe FTP directly the index page but thats a lot of pages (border info was changed on all pages including index.html).

  4. #4
    Senior Member franko's Avatar
    Join Date
    Apr 2010
    Location
    Tasmania Australia
    Posts
    2,507

    Default

    Try a clean Local Publish. Delete the contents of the Local Publish folder first and then do a full Local Publish. Then use a dedicated ftp program to upload the pages you want changed on the server. This is my workflow for all site uploads and I've never encountered a problem doing it. You have /Preview/ in your path; are you trying to upload from the Preview folder? If so, don't; it's not a publish. Only upload from a clean Local Publish or from NoF's Remote Publish (although I never do this; I prefer to have a clean Local Publish so I can check it thoroughly before uploading to the production server).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •