Results 1 to 10 of 10

Thread: External Links in PNG images??

  1. #1
    Junior Member
    Join Date
    Jul 2015
    Posts
    25

    Default External Links in PNG images??

    I've done some searching on the web to find out whether it is not a good practice to try to put links in PNG images. NOF allows you to do this, but after publishing instead of taking the user to the link target the browser just displays the image in the middle of the page while the background is dimmed. If I substitute a gif or jpg image, then all functions as you'd expect. Is this NOF, or just ignorance of PNG image properties perhaps? I tried changing my publishing from Parent Setting to HTML 4.01 to HTML 5, but that did not change the behavior. I wasn't finding anything which indicated png's should not have links in them. The HTML within NOF looks correct. Thank You.

  2. #2
    Senior Member gotFusion's Avatar
    Join Date
    Jan 2010
    Location
    www.gotHosting.biz
    Posts
    4,529

    Default

    Select the link button on the image palette
    Select external link from the drop down
    enter your external URL


    Click image for larger version. 

Name:	picture-link2.gif 
Views:	49 
Size:	29.5 KB 
ID:	2656
    NetObjects Fusion Cloud Linux enabled Web Hosting, support + training starts at $14.95
    NetObjects Fusion web Hosting and support + ASP + PHP + ColdFusion + MySQL + MS SQL
    FREE NetObjects Fusion Support & training comes with all web hosting accounts
    NetObjects Fusion Web Hosting: http://www.gotHosting.biz

  3. #3
    Junior Member
    Join Date
    Jul 2015
    Posts
    25

    Default

    Thank You for your reply, but my problem is not that I don't know how to set an external link. It is that once the page is published instead of the clicked image leading to its defined target, the browser (Chrome , Firefox, Internet Explorer) all just display the image with my external link in the middle of the browser rather than going to the link target. This behavior does not occur with .gif or .jpg images. Only with .png images. I'm using NOF15.

  4. #4
    Senior Member gotFusion's Avatar
    Join Date
    Jan 2010
    Location
    www.gotHosting.biz
    Posts
    4,529

    Default

    Post a URL
    NetObjects Fusion Cloud Linux enabled Web Hosting, support + training starts at $14.95
    NetObjects Fusion web Hosting and support + ASP + PHP + ColdFusion + MySQL + MS SQL
    FREE NetObjects Fusion Support & training comes with all web hosting accounts
    NetObjects Fusion Web Hosting: http://www.gotHosting.biz

  5. #5

  6. #6
    Senior Member RayC's Avatar
    Join Date
    Apr 2010
    Location
    Toronto-ish, Canada
    Posts
    1,732

    Default

    • Select the image (PNG) that you want to use as a link.
    • Click on the "Link" button at the top of the NOF window. If you don't see that button, use the Object menu and select Link... or press CTRL-K
    • In the window that opens, choose "External Link" from the drop-down.
    • Enter the URL in the "New link:" field. The drop-down beside the field should default to "http://", which is what you will want 99% of the time. Just make sure that is selected.
    • If you want the link to open in a new window or tab, at the bottom where is says "Target", select "Existing" from the drop-down. When "Name:" appears, leave it as "_blank"
    • Link the [Link] button.


    Click image for larger version. 

Name:	ExternalLink.png 
Views:	53 
Size:	56.4 KB 
ID:	2658
    Ray Cambpell
    Sounds In Sync
    Linked in

  7. #7
    Junior Member
    Join Date
    Jul 2015
    Posts
    25

    Default

    The issue is not with the process of establishing a link to an image. I'm fully aware of how to do that. The problem (and I see it with Chrome, Firefox, and Internet Explorer, is that on the published page the PNG image files in the footer are not getting linked to their href targets. If you mouse over the image you will see the filename in the lower left corner of the browser, rather than the URL that it should be pointed at. I have checked the NOF HTML code and the anchor tag shows:

    <a id="Picture317A" href="https://www.youtube.com/channel/UCPHD5IgG-fAI2LFY8G7mG4Q" target="_blank" NOFINSIDE=~! !~>
    <img id="Picture317" height="100" width="100" src="file:///C:/Users/IBM_ADMIN/Documents/NetObjects Fusion 2015/User Sites/IRMCMod/IRMCMod/Preview/Autogen/YouTubeFooter.png" alt="YouTubeFooter" title="YouTubeFooter" NOFINSIDE=~! !~>
    </a>

    So you can see that the href attribute points to the URL I want. I've checked the HTML code on the web server as well and it shows it being properly linked. So, I am not sure why this is not being recognized by the browsers as an image that is linked to another URL. I'm not sure what the ~! !~ characters do inside of the tags or if they are somehow related to this.

  8. #8
    Senior Member
    Join Date
    Apr 2010
    Location
    Sydney
    Posts
    1,888

    Default

    Quote Originally Posted by erlebc View Post
    you have several things wrong, your are using the wrong HTML output with UTF8, be sure to use HTML5 and UTF8

    also, remove any center code you inserted manually

    see attached video showing how it works with your image
    https://www.videoproductions.com.au/...Anton-0079.mp4

  9. #9
    Junior Member
    Join Date
    Jul 2015
    Posts
    25

    Default

    Thank You. I appreciate the effort to compose the video. At first all worked fine. But then after adding the rest of the images it was back to the originally reported behavior. I finally discovered that everything worked fine as long as I did not resize the image. As soon as I did that the image no longer honored the URL link, but instead reverts back to just displaying the png file. Odd behavior, but I'll just resize them outside of NOF and then replace them, and hopefully all will be as expected. Strange behavior to say the least.

  10. #10
    Senior Member
    Join Date
    Apr 2010
    Location
    Sydney
    Posts
    1,888

    Default

    ahahhh, I always resize and optimize images outside Nof (Photoshop and save for web)

    make sure you disable all image optimize options in Nof, for gif, png and jpg
    https://www.videoproductions.com.au/...timize-off.png

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •