Results 1 to 2 of 2

Thread: Is php code from NOF 11 compatible with php 7+ ?

  1. #1
    Junior Member
    Join Date
    Feb 2019
    Posts
    1

    Question Is php code from NOF 11 compatible with php 7+ ?

    I have a website that was written using NOF 11 for Windows, but I need to update server version of php from 5.6 ideally to 7.2.

    Does anyone know whether this is possible or it will break it?

    I personally do not use NOF and find the code very unreadable and bloated with the table structure. A complete rewrite would be a pain in the neck and take a long time!

  2. #2
    Senior Member chuckj's Avatar
    Join Date
    Jan 2010
    Location
    www.beyondfusion.com - Florida
    Posts
    1,293

    Default

    Fusion uses deprecated database connection scripts that are not supported in PHP 7.x. They work with any flavor of PHP 5.x.x.

    One of these days, I'm going to rewrite the Fusion scripts fir PHP 7 and post them on my website.
    Chuck Joslin
    www.BeyondFusion.com
    PHP & MySQL development with Fusion
    Fusion support for AllWebMenus (Likno) Contact me for custom AWM menus for your sites.
    Tutorials and Forums

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •