Results 1 to 5 of 5

Thread: Mail script suddenly not working

  1. #1

    Default Mail script suddenly not working

    I have a "contact us" page with a script that has worked for years. Last week, clients started telling me that it was throwing an error message. When I tried it, I got this:

    "[Error 110] Email template file /home/DIRNAME/DIRNAME.US/scripts/fh_emailTemplate_s.properties not found. Please publish your site again."

    Looking back through the history of my site, there has NEVER been a file called "fh_emailTemplate_s.properties" associated with it.

    I do not have any such file in my local system. There's none on the server. There's no such file in any templates that I've saved in the last 15 years of producing this site.

    Any ideas why this might be happening? Better: any idea how to fix it? (I haven't done any coding in over a decade, so I'm UBER rusty on this.)

  2. #2
    Senior Member franko's Avatar
    Join Date
    Apr 2010
    Location
    Tasmania Australia
    Posts
    2,639

    Default

    Is it a php or microsoft script thingy that it calls to process the form? As NoF is now so ancient it's quite likely that the script language on the server has been updated and no longer works with NoF. For example, I don't think PHP 5 will work with NoF, which requires an older version of the script. This is the most likely cause and unfortunately, unless you're a programmer in either PHP or the microsoft scripting language (never used microsoft so can't even remember what it's called) and can rewrite the script I think you're probably screwed. Only recourse will be to use an external form service and simply cut and paste their code into your page.

  3. #3

    Default

    Likely to be the PHP version. NOF will still work with PHP 5.6....but not on newer versions.
    Ask your hosting company what version they have in place (most are on 7.x).
    You should be able to revert back to PHP 5.6 with most hosting companies for the sites affected.
    I had to do that for a few websites.

  4. #4
    Senior Member
    Join Date
    Apr 2010
    Location
    Sydney
    Posts
    1,944

    Default

    any webhost can set the php version for your site to 5.6 and then it will work

    I am a host and it takes 10 sec to do this

  5. #5
    Banned
    Join Date
    Mar 2020
    Posts
    10

    Default

    Looking back through the history of my site, there has NEVER been a file called "fh_emailTemplate_s.properties" associated with it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •