Thanks for the help.

I used the Publish Site from Fusion 9 and published the entire site.

Any ideas as to why it does not publish properly? This only happens with
the pages that have the Guestbook feature.

"Hobbit" <hobbitworld@hotmail.com> wrote in message
news:e47l3o$1n24@flsun90netnews01.netobjects.com.. .
> David,
>
> If I remove the following code from your source and save as '.html' you
> page loads OK:
>
> <%
> nof_rootDir="../"
> nof_scriptDir="scripts"
> nof_debug=false
> nof_sitePath = GetSitePath(nof_rootDir)
>
> function GetSitePath(RootDir)
> Dim relPath
> relPath = split(RootDir, "/")
> forwardSteps = UBound(relPath) - 1
> if forwardSteps = 0 and relPath(0) = "." then forwardSteps = -1
> GetSitePath = Server.MapPath(".")
> for idx=0 to forwardSteps
> GetSitePath = Left(GetSitePath, inStrRev(GetSitePath, "\") - 1)
> next
> GetSitePath = GetSitePath & "\"
> end function
> %>
> <%
> sub IncludeLib(ByVal lib, ByVal sitePath, ByVal scriptDir)
> dim fso, f, buf, filePath
>
> Set fso = Server.CreateObject("Scripting.FileSystemObject")
> filePath = sitePath & scriptDir & "\" & lib
> if fso.FileExists(filePath) then
> set f = fso.OpenTextFile(filePath, 1, false, -2)
> buf = f.ReadAll
> f.close()
> set f = nothing
>
> Dim regEx
> Set regEx = New RegExp
> regEx.Pattern = "^\s*<" & chr(37) & "\s*"
> regEx.IgnoreCase = True
> regEx.Global = True
> buf = regEx.Replace(buf,"")
> regEx.Pattern = "\s*" & chr(37) & ">\s*$"
> regEx.IgnoreCase = True
> regEx.Global = True
> buf = regEx.Replace(buf, "")
> set regEx = nothing
>
> ExecuteGlobal buf
> else
> if nof_debug then
> Response.Write "Could not include the file `" & filePath & "`."
> else
> Response.Write "<p>An error occured. Please contact the site
> administrator.</p>"
> Response.Write "<p>Error code: 103</p>"
> end if
> Response.End
> end if
>
> set fso = nothing
> end sub
> %>
> <%
> call IncludeLib("gb_XmlLib.asp", nof_sitePath, nof_scriptDir)
> call IncludeLib("gb_CdoMail.asp", nof_sitePath, nof_scriptDir)
> %>
> <%
> call IncludeLib("gb_admin.asp", nof_sitePath, nof_scriptDir)
> %>
>
> Should this be located between the HEAD tags or else where??
>
> Kevin.
>
>
>
> "Hobbit" <hobbitworld@hotmail.com> wrote in message
> news:e47h6m$1n32@flsun90netnews01.netobjects.com.. .
>> David,
>>
>> I just see your code (source)..
>>
>>
>> <David> wrote in message
>> news:e47gu4$1n31@flsun90netnews01.netobjects.com.. .
>>> Thanks for the review. I'm not sure what you are referring to.
>>>
>>> When I bring up the "Guest Comments" page, I get a form that allows to
>>> submit information.
>>>
>>> At the bottom is where I get the error.
>>>
>>> That's the part I am having trouble with.
>>>
>>> Any help is greatly appreciated.
>>>
>>> "Hobbit" <hobbitworld@hotmail.com> wrote in message
>>> news:e47fo0$1n21@flsun90netnews01.netobjects.com.. .
>>>> David,
>>>>
>>>> I don't know ASP, but your page just loads as plain text. Should you
>>>> have
>>>> something at the HEAD of your page which identifies it as HTML?
>>>>
>>>> Regards,
>>>>
>>>> Kevin.
>>>>
>>>>
>>>> <David> wrote in message
>>>> news:e47clc$s41@flsun90netnews01.netobjects.com...
>>>>> www.trailcreekvt.com
>>>>>
>>>>> After clikcing on "Guest Comments", (scroll to the bottom) the user
>>>>> gets:
>>>>>
>>>>> An error occured. Please contact the site administrator.
>>>>>
>>>>> Error code: 540
>>>>>
>>>>> I can't find this error code in the documentation and I can't figure
>>>>> out
>>>>> why this is happening.
>>>>>
>>>>> The same thing happens with the Guestbook Admin feature on the "Board
>>>>> Use
>>>>> Only" page.
>>>>>
>>>>> Can someone tell me what I'm doing wrong?
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>

>>
>>
>>

>
>