Results 1 to 4 of 4

Thread: Mouseover Action Error

  1. #1

    Default Mouseover Action Error

    I keep getting these error's when I try to do a mouse over action - I am trying to make one picture show up on load and another to show on mouse over - I set the action as follows:
    Action 1 - On Page Loaded do Set Image (set Values for my 2 pictures)
    Action 2 - On Mouse Over do Use Image (Parameter: Use Image 2 (Highlighted)
    Action 3 - On Mouse Out do Use Image (Parameter: Uses Image 1 (Normal)

    When I do Page Preview I get the following errors:

    Line: 30
    Char: 125
    Error: Expected "j"
    Code: 0
    URL: File://C:\Program Files\NetObjects\NetObjects Fusion Essentials\User Sites\JordanValleyGlassworks\Preview\Frogs.html

    and

    Line: 2637
    Char: 3
    Error: 'F_doLoaded' is undefined
    Code: 0
    URL: File://C:\Program Files\NetObjects\NetObjects Fusion Essentials\User Sites\JordanValleyGlassworks\Preview\Frogs.html

    Can somebody help me with this?

    Thanks,
    Bill

  2. #2
    Senior Member barbara0701's Avatar
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    1,184

    Default

    Do you have all necessary updates?

    I use a different method for mouseover effects, maybe this can help:


    Insert the first pic normally in page view. Include the second picture in your assets.

    Now klick on the first picture an add the following code within tag:

    Code:
    Code:
    name="button1"
    onMouseover="button1.src='../assets/images/button2.gif';"
    onMouseout="button1.src='../assets/images/button1.gif';"
    button1.gif and button2.gif being the exact file names for my pictures as an example - but you would use yours instead.

    If your action is used on your "Home" page, please remove one point from the link: ./ instead of ../

    Hope this helps.

  3. #3
    Senior Member gotFusion's Avatar
    Join Date
    Jan 2010
    Location
    www.gotHosting.biz
    Posts
    4,526

    Default

    Quote Originally Posted by jvglassworks View Post
    I keep getting these error's when I try to do a mouse over action - I am trying to make one picture show up on load and another to show on mouse over
    Have you tried the Picture Roll Over component? It was designed to do just what you are trying to do with an action. see attached screen shot for where this component is located

    Click image for larger version. 

Name:	customComponents&#.gif 
Views:	295 
Size:	13.9 KB 
ID:	87
    NetObjects Fusion Cloud Linux enabled Web Hosting, support + training starts at $14.95
    NetObjects Fusion web Hosting and support + ASP + PHP + ColdFusion + MySQL + MS SQL
    FREE NetObjects Fusion Support & training comes with all web hosting accounts
    NetObjects Fusion Web Hosting: http://www.gotHosting.biz

  4. #4
    Senior Member barbara0701's Avatar
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    1,184

    Default

    By the way, could it be that NOF was not installed and started as an administrator?

    There can be many causes for a problem like that... I would test the component on a new project, just to see if it the problem only occurs on one project. It would be nice to know your nof version and your OS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •